Search found 1966 matches

by VilleK
Fri Jan 18, 2019 10:16 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

Ok then maybe it is TZApplication.Init method that is called too early on the problematic phone so that the initial value (via TGLDriverBase.InitGL) of GL_DEPTH_TEST is not properly set?
by VilleK
Fri Jan 18, 2019 7:55 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

BitmapLoad also leads to a call to GLESPixelsFromTexture so it is still the same issue. I suspect this line in ZOpenGL (line 1715) is not working on this phone: glGetIntegerv(GL_DEPTH_TEST, @A^.Depth); Perhaps also for the cull face setting. You can try always renabling depthtest like this, in fakeP...
by VilleK
Wed Jan 16, 2019 2:17 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

I don't see how it could be a bug in ZGE? The code for save and restore the values in fakePush/Pop looks correct to me.
by VilleK
Tue Jan 15, 2019 7:53 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

Kjell wrote:
Mon Jan 14, 2019 8:32 pm
Ah right, the fakePushAttrib / fakePopAttrib procedures .. not sure what's going on then :-(
It could be a driver bug that the glGetIntegerv (used in PushAttrib) doesn't get the correct value for one or more of the flags. Which ends up with wrong values for face culling etc.
by VilleK
Mon Jan 14, 2019 7:46 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

Kjell: Yes I saw that but it saves and restores previous setting (via platform_android push/pop attrib).
by VilleK
Mon Jan 14, 2019 11:48 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 82
Views: 14885

Re: OMEGANAUT

I checked the source code for BitmapCombine and I can't see a way that would fail unless the OpenGL driver for the device is buggy. Which, sadly, might be a possibility.
by VilleK
Mon Jan 07, 2019 12:11 pm
Forum: General discussion
Topic: ZGameEditor & Android Setting
Replies: 85
Views: 9706

Re: ZGameEditor & Android Setting

Please note that the lib file itself has no dependency to a specific API-level, as far as I know. So you should be able to use the same .so file in a API 16 apk. Indeed if there is no floating point option set enabled (which is what CfVFPv2 does) then performance will suffer. So you might need to re...
by VilleK
Mon Jan 07, 2019 9:26 am
Forum: General discussion
Topic: ZGameEditor & Android Setting
Replies: 85
Views: 9706

Re: ZGameEditor & Android Setting

Thanks for the update, I was wondering about your progress on this. When exported to API 16, the game runs at a constant 60 fps. But when it is exported to API 26, I get huge drops from time to time (15 fps). Do you mean this happens when using the same libzgeandroid.so for API 16 and 26? So it cann...
by VilleK
Sat Jan 05, 2019 1:51 pm
Forum: Your projects
Topic: 彩虹子彈
Replies: 6
Views: 163

Re: 水果子彈

Works fine and smooth here. Nice difficulty curve. I like vertical scrolling shoot'em ups :)
by VilleK
Fri Dec 28, 2018 8:55 am
Forum: Your projects
Topic: GK 64k
Replies: 2
Views: 64

Re: GK 64k

Thanks. It is still quite difficult but fun. I think you should promote these mini-games of yours some more, they deserve a larger audience than the few of us here at ZGE forums :)
by VilleK
Thu Dec 20, 2018 8:29 pm
Forum: General discussion
Topic: ZGameEditor & Android Setting
Replies: 85
Views: 9706

Re: ZGameEditor & Android Setting

Hej Ville, Based on this I would assume that on Android GL_BLEND is enabled by default somehow? That doesn't have anything to do with blending ( vertex colors mix with the material diffuse color without having to use blending ). It's because when you don't explicitly set certain components of the v...
by VilleK
Thu Dec 20, 2018 3:04 pm
Forum: General discussion
Topic: ZGameEditor & Android Setting
Replies: 85
Views: 9706

Re: ZGameEditor & Android Setting

Based on this I would assume that on Android GL_BLEND is enabled by default somehow?

Can you try adding "glDisable(GL_BLEND);" in OnRender, or in OnLoad?
by VilleK
Thu Dec 20, 2018 12:17 pm
Forum: General discussion
Topic: ZGameEditor & Android Setting
Replies: 85
Views: 9706

Re: ZGameEditor & Android Setting

I checked the code and ZGE does not set any default values for the mesh colors so alpha can be any value (but most likely zero). What material do you render your mesh with? Does it use blending or not? For some reason I guess that on Android it uses blending but not on Windows.
by VilleK
Thu Dec 20, 2018 9:06 am
Forum: Your projects
Topic: AS 64k
Replies: 6
Views: 198

Re: AS 64k

rrTea wrote:
Thu Dec 20, 2018 7:38 am
Anyway I made a page for the project: https://q64.itch.io/as64k
I like your comic strips :D
by VilleK
Wed Dec 19, 2018 8:03 am
Forum: Your projects
Topic: AS 64k
Replies: 6
Views: 198

Re: A.S.64k

About saving space: the "Find unused components" option in Tools menu can help sometimes.