Interface glitches

Found a bug? Post information about it here so we can fix it!

Moderator: Moderators

User avatar
rrTea
Posts: 323
Joined: Sat Feb 15, 2014 9:54 am

Re: Interface glitches

Post by rrTea » Tue Jan 05, 2016 9:22 am

That was fast, thanks!

User avatar
rrTea
Posts: 323
Joined: Sat Feb 15, 2014 9:54 am

Re: Interface glitches

Post by rrTea » Fri Jan 22, 2016 10:24 am

Autocomplete sometimes adds things at the beginning instead of at the end. In the attached video this will result in the Attribute.Component instead of Component.Attribute.

Edit: this usually happens in combination with other glitches, for example pressing Shift + Right will select the whole line (instead of selecting whatever is immediately after the cursor) etc.
Attachments
Capture-072.avi
Expected: "CannonBulletLaunch.Interval"
(468.5 KiB) Downloaded 51 times

User avatar
rrTea
Posts: 323
Joined: Sat Feb 15, 2014 9:54 am

Re: Interface glitches

Post by rrTea » Wed Jan 27, 2016 3:05 am

Preview of meshes doesn't update automatically anymore (with the newest build 4.0b).

Steps to reproduce:
1. In an empty project add the "Superformula" mesh from the Library.
2. Click on the newly added mesh so the Preview windows shows it.
3. Open the Mesh "Superformula" / Producers / MeshExpression.
4. Line 6, change the value to something like 10 and hit "Compile".
...but the preview does not update until it is actually clicked on and the mesh is rotated.

This was working correctly one build back.

User avatar
VilleK
Site Admin
Posts: 1924
Joined: Mon Jan 15, 2007 4:50 pm
Location: Stockholm, Sweden
Contact:

Re: Interface glitches

Post by VilleK » Wed Jan 27, 2016 10:05 am

Thanks, I've fixed that now and uploaded a new version.

User avatar
rrTea
Posts: 323
Joined: Sat Feb 15, 2014 9:54 am

Re: Interface glitches

Post by rrTea » Thu Jan 28, 2016 3:16 am

Thanks!... Since there's a new beta from now on I'll post this kind of reports in the other thread.

Post Reply