upgrading to new version app.collided error

All topics about ZGameEditor goes here.

Moderator: Moderators

Post Reply
jinxtengu
Posts: 80
Joined: Wed Oct 14, 2009 2:05 pm
Contact:

upgrading to new version app.collided error

Post by jinxtengu » Tue Jun 11, 2019 4:41 am

Hi Z game forums,
I just downloaded the newest version of z game editor (version 4.0) and tired out a game im working on (version 1.9.9).
I get an error upon running: Unknown property: CollidedCategory.
I'm assuming the syntax has changed for collision conditions.

my syntax is currently like this:
return app.CollidedCategory==2;

Iv'e tried changing this to
"CurrentModel.CollidedWith.Category==2"
but then I get an error
invalid statement expression

Can someone please tell me how should I change these instances?

User avatar
VilleK
Site Admin
Posts: 2029
Joined: Mon Jan 15, 2007 4:50 pm
Location: Stockholm, Sweden
Contact:

Re: upgrading to new version app.collided error

Post by VilleK » Tue Jun 11, 2019 8:21 am

Hi,

This syntax works here:

Code: Select all

int test() {
  return CurrentModel.CollidedWith.Category==2;
}
Make sure you are using the version you can download here: viewtopic.php?f=2&t=1320

jinxtengu
Posts: 80
Joined: Wed Oct 14, 2009 2:05 pm
Contact:

Re: upgrading to new version app.collided error

Post by jinxtengu » Wed Jun 12, 2019 1:45 am

Thanks. Sorry to ask such simple questions.

Post Reply