Search found 414 matches

by Ats
Wed May 05, 2021 3:33 pm
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

Here's the result on the old Galaxy SII (2011):
Screenshot_20210505-173054_Test_GL_BLEND.png
Screenshot_20210505-173054_Test_GL_BLEND.png (20.75 KiB) Viewed 39 times
by Ats
Wed May 05, 2021 11:18 am
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

Here's the last GL_BLEND test if that can avoid you to setup the entire Android environment :wink:
by Ats
Wed May 05, 2021 10:51 am
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

Oh, I thought it was part of the bug :lol:
Screenshot_20210505-125032.png
Screenshot_20210505-125032.png (19.23 KiB) Viewed 56 times
by Ats
Wed May 05, 2021 10:33 am
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

Screenshot_20210505-123225.png
Screenshot_20210505-123225.png (19.13 KiB) Viewed 68 times
By the way, my Android device is a Google Pixel 3A, so pretty standard when it comes to Android :wink:
by Ats
Wed May 05, 2021 7:13 am
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

I made some tests regarding that bit of code.

Here's the result for when there's only "glDisable(GL_BLEND);"
Screenshot_20210505-090424.png
Screenshot_20210505-090424.png (121.86 KiB) Viewed 76 times

And only "glEnable(GL_BLEND);"
Screenshot_20210505-090957.png
Screenshot_20210505-090957.png (113.48 KiB) Viewed 76 times

So A.Blend could be switching on/off for no reason somewhere?
by Ats
Tue May 04, 2021 1:18 pm
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

All right. Otherwise, this could be hidden behind an {$IFDEF ANDROID}

Does this block of code affect targets other than Android? (in order to run tests)
by Ats
Tue May 04, 2021 12:11 pm
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

Re: One in two BitmapFont lose transparency on Android

Yes I'm sure. And I tried again one more time in order to verify again.

With this change, the fonts appears correctly on Android :wink:
by Ats
Tue May 04, 2021 10:48 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

try switching to ES2/GL3 then saving the file as ShaderDemoES2 and then reloading it. Maybe it's using cached shader objects or something. I did that and it's still the same. Switching to ES2/GL3 seems to be not simple and with random results... I'm not sure if I want to do that. (but I'll do it an...
by Ats
Tue May 04, 2021 7:55 am
Forum: Bug reports
Topic: One in two BitmapFont lose transparency on Android
Replies: 14
Views: 123

One in two BitmapFont lose transparency on Android

There is a bug on Android with fonts. It was hard to track down . So I made a simple test to show it up: <?xml version="1.0" encoding="iso-8859-1" ?> <ZApplication Name="App" Caption="Test Font" ClearColor="0.251 0.502 0.502 1" FileVersion="2" AndroidPackageName="com.txori.test_font"> <OnRender> <Us...
by Ats
Tue May 04, 2021 7:23 am
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

Linux + Wine The GL Shaders version is 4.60 GLES2Demo wine_ESGL2_compatible_460 (1).png "precision mediump float;" has to be deactivated otherwise it crashes. And I didn't see that there was a shader for the text too yesterday. ShaderDemo (switched to ES2/GL3) Screenshot_2021-05-04_09-07-17 (1).png...
by Ats
Mon May 03, 2021 8:27 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

And you where right. The drivers are tripping. Or maybe it's another problem with linux. I'll investigate tomorrow :wink:
by Ats
Mon May 03, 2021 7:26 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

It's not crashing without "precision mediump float;" but the result isn't impressive:
Screenshot_2021-05-03_21-22-19 (1).png
Screenshot_2021-05-03_21-22-19 (1).png (16.81 KiB) Viewed 71 times
I'll try on the other computer tomorrow :wink:
by Ats
Mon May 03, 2021 7:14 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

With #version 140 I get new errors: Error in Vertex shader compilation (Shader1) Òÿÿœ°2 Error in Vertex shader compilation (Shader1) VW@ Error in Vertex shader compilation (SpriteShader) üËÿÿ¼°2 On the other hand, ShaderDemo.zgeproj is working fine, and even display a flattened teacup without error ...
by Ats
Mon May 03, 2021 6:53 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

Yes. I'm currently viewing the GLES2Demo and ES2/GL3 is activated.
by Ats
Mon May 03, 2021 6:45 pm
Forum: Your projects
Topic: OMEGANAUT
Replies: 92
Views: 62570

Re: OMEGANAUT

If you want to use shaders on Android make sure to check out GLES2Demo.zgeproj in the Projects folder that comes with ZGE. That's exactly what I was looking at while you were responding :lol: But I can't get it to work: Error in Vertex shader compilation (Shader1) 0:1(1): error: syntax error, unexp...