Problem with Fullscreen - solved

Found a bug? Post information about it here so we can fix it!

Moderator: Moderators

Post Reply
User avatar
Rado1
Posts: 770
Joined: Wed May 05, 2010 12:16 pm

Problem with Fullscreen - solved

Post by Rado1 » Sun Aug 07, 2016 3:49 pm

With the current beta it is not possible to run the saved application in windowed mode. It seems that ZApplication.FullScreen is always applied even if the checkbox is unchecked. Setting ZApplication.ScreenMode just influences the resolution of viewport spread over the whole screen.

When runing with ZApplication.ShowOptionsDialog, the dialog initially shows the checkbox unchecked, even if it behaves as if checked. After clicking on it, the checkbox does not change, but it became actually unchecked internally. After this first click, the checkbox shows values correctly.

To reproduce the problem:
1. Create new empty project -> no problem, it runs in window 800x600.
2. Save it.
3. Run it again -> it runs in fullscreen .

Older projects saved previously work fine. I thing the problem is in saving a project.

I'm running on Windows 10 with AMD FirePro M2000 having (hopefully) the latest drivers.

My testing project:

Code: Select all

<?xml version="1.0" encoding="iso-8859-1" ?>
<ZApplication Name="App" Caption="BBB" ScreenMode="1" MouseVisible="255" FileVersion="2" AndroidPackageName="com.rado1.bbb"/>

User avatar
VilleK
Site Admin
Posts: 1947
Joined: Mon Jan 15, 2007 4:50 pm
Location: Stockholm, Sweden
Contact:

Re: Problem with Fullscreen

Post by VilleK » Sun Aug 07, 2016 5:52 pm

Hi, this sound like something that must be fixed. I'm on vacation for another week but will look at it when I get back. And please remind me if I seem to forget :).

User avatar
rrTea
Posts: 334
Joined: Sat Feb 15, 2014 9:54 am

Re: Problem with Fullscreen

Post by rrTea » Mon Aug 08, 2016 4:45 am

I run into a similar problem, if it's not related (sorry if so) we can separate it I guess?

Running something in "Use Desktop Resolution" mode sometimes "hugs" the desktop, in other words if I launch the program and later press something like Alt-Tab or Windows key (to show the Windows menu) the ZGE program will still stay on top of everything... but the mouse and key inputs are all sent behind.

In such cases pressing for example "Esc" doesn't help because the focus is "behind". The only thing to do is to press Alt-Tab, press "Esc" to see whether the focus is on ZGE program, and repeat as many times as needed till you hit it.

This only happens on one of my computers (a laptop with Windows 10) as far as I know.

User avatar
Rado1
Posts: 770
Joined: Wed May 05, 2010 12:16 pm

Re: Problem with Fullscreen

Post by Rado1 » Wed Aug 17, 2016 2:31 pm

Solved! The problem was that the project was named "wt-f.zgeproj" and was placed in a directory named "wt-f". When running from exe, ZGE think that -f from path name is a commandline option -f. So recommendation for you: avoid usage of "-f" (force fullscreen), "-w" (force windowed) or "-s" (no sound) in names of your projects or directories where the compiled exe files are running from.

To rrTea: I cannot reproduce the issue you described on my Win 10 PC.

User avatar
Kjell
Posts: 1669
Joined: Sat Feb 23, 2008 11:15 pm

Re: Problem with Fullscreen

Post by Kjell » Wed Aug 17, 2016 3:04 pm

Hi guys,
Rado1 wrote:The problem was that the project was named "wt-f.zgeproj" and was placed in a directory named "wt-f".
Had a quick look at the source, and Platform_CommandLine is a bit naive in its implementation. It's pretty easy to fix though, Windows even has a built-in function to parse the arguments ( CommandLineToArgv ).

K

User avatar
rrTea
Posts: 334
Joined: Sat Feb 15, 2014 9:54 am

Re: Problem with Fullscreen

Post by rrTea » Thu Aug 18, 2016 1:36 am

Sounds like the problem on one of my computers is completely unconnected after all...
Rado1 wrote:To rrTea: I cannot reproduce the issue you described on my Win 10 PC.
I also can't trigger it on both of my computers, only one (both work great otherwise and have the newest drivers etc).

Post Reply